
Welcome to soundsaVR®, the wired sprite QTVR editing tool that embeds directional stereo sound into 
single
or multinode panoramamovies.
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System Requirements 
---------------------------------------------------------------------------------------------------------------- 
soundsaVR requires a Macintosh PowerPC or compatible system with a base requirement of 5 MB of 
RAM and
5 MB of hard disk space for installation. The sounds and VR movies used will require additional hard 
disk space
and memory. A recommended system configuration for adding sounds to VR movies is 16 MB RAM and 
50 MB
of hard disk space.    soundsaVR requires QuickTime 3.0 to be installed, and requires System 8 or 
higher. 
Sound Manager 3.3 should also be installed as some compression codecs require it. 
    

Usage Notes 
---------------------------------------------------------------------------------------------------------------- 
Adding sounds using soundsaVR should be the last step in the QTVR authoring process. This is due to a
special
flattening process that permits QuickTime to loop sounds without storing it multiple times. As 
QuickTime
editing software calls the default QuickTime flattening function, when a soundsaVR movie is re-
flattened it
will grow in size. Only soundsaVR is capable of flattening soundsaVR movies. 

Modifications using other editors such as Movie Player will work as long as the movie is not flattened.    
To
flatten the movie, open it with soundsaVR and save the movie again. 

soundsaVR preserves embedded media such as custom graphics or wired sprites. This is designed to 
provide
further compatibility with custom authored panoramas. Note that object movies are not supported. 

Developers who are using authoring packages with scripting capabilities such as Director or mTropolis, 
should
take note that each node is set to a length of one hour so that sounds can independently loop.    At the 
end of
each hour the movie will transition to the next sequential node in the movie file. 
    

Quick Start 
---------------------------------------------------------------------------------------------------------------- 

              Launch soundsaVR 
              Open a QTVR movie with NO object nodes 

              Add sounds to all nodes (repeat as necessary) 
                      Select a node in the movie 
                            Import required sound files 
                                        Click the "Add Sound..." button 
                                        Choose a sound file from the dialog 
                                        Repeat until all required sounds have been imported
                            Set the correct direction for sounds that should pan 



                                        Select a sound from the "Sounds" list box 
                                        Pan the movie to the desired angle 
                                        Click the "Set Angle" button 
                                        Repeat until all directional sounds have been set correctly
                            Set the volumes for each sound 
                                        Select a sound from the "Sounds" list box 
                                        Drag the volume slider(s) to the desired level 
                                        Repeat until all sound volumes have been set as desired
                            Set the output options 
                                        Choose the "Save Options..." menu item from the "Edit" menu 
                                        Configure the checkbox options as desired.

              Set the output options 
                      Choose the "Save Options..." menu item from the "Edit" menu 
                      Configure the checkbox options as desired.

              Save the output movie 
                      Select "Save A Copy As...." menu item from the "File" menu 
                      Choose the file destination from the dialog

 ---------------------------------------------------------------------------------------------------------------- 
    

The Menu Bar 
---------------------------------------------------------------------------------------------------------------- 
There are three active menu bar items in soundsaVR: File, Edit and Options. 
The File menu has four active items: "Open...", "Close",    "Save A Copy As...",    and "Quit" 

The "Open... " menu item will open a dialog to select a movie file.    Importing a file that has no 
panorama track
or QTVR track will cancel the process and the user will be notified that the file was not a panorama.    
When a
valid QTVR movie has been selected, a soundsaVR editing window will open, displaying the selected 
movie file. 

The "Close" menu item will close the active editing window.    If the movie has been edited, and the 
changes
haven't been saved, a dialog will open prompting the user to save before closing the movie, to close 
without
saving, or to cancel. 

The "Save A Copy As..." menu item will open a standard put-file dialog allowing the user to save the 
current
movie with edited sounds.    It is recommended that users do not try to overwrite already existing files. 

The "Quit" menu item will close all editing windows and Quit the application.    As with the Close menu 
item, the
user will be prompted to save any changes. 

The Edit menu has one active item; the "Save Options..." menu item will open a dialog allowing the 
user to
select from three checkboxes that determine output format.    Selecting the "Fast Start Movie" check 
box will
specify that when the movie is saved out it will support progressive video downloading.    When this 
option is
activated both the "Pre Load Audio" and "Fast Start Audio" check box will be enabled and selected. "Pre
Load
Audio" specifies that all audio tracks will be downloaded before any of the video.    If the "Fast Start 



Audio"
option is not selected audio will not auto start play until the movie has been completely downloaded.    
In some
scenarios, if wired sprite pause/play controls are added to the movie, the end user can override the 
behavior
you set by initiating audio fast start. See the section "Save Options In Detail" later in this document for
more
details. 

The Options menu has nine active items: the first two, "Degrees" and "Cross Hairs", toggle the info 
displays on
and off.    The remaining six menu items set the color of the information displays.    The info displays 
check the
dimensions of the panorama track, not the entire movie, and are therefore always placed in their 
correct
positions even if a panorama track has been rotated or if additional media elements have been added 
to the
movie. 
    
    

The soundsaVR Editing Window 
---------------------------------------------------------------------------------------------------------------- 
Multiple soundsaVR editing windows can be opened simultaneously, depending on available memory.    
Several
copies of the same movie file can be opened simultaneously in order to save different versions of the 
movie,
and to compare differences in settings. Clicking the windows "zoom box" will reset the window to its 
original
size if it has been changed. 

The soundsaVR Editing Panel 
Each window contains an editing panel on the left side, that has a "Node List", and "Sound List",    as 
well as
buttons to add or delete sounds, and controls that set the volume(s), type (ambient or directional), and
looping status of each imported sound. 

Add Sound... Button 
Clicking on this button will open a dialog box where an appropriate sound file can be selected in the 
get-file list
box.      Clicking on Open will import the selected sound into the current node and display it in the 
'Sounds' list
box.    Previously grayed out items in the soundsaVR editing panel will become active.    If a sound file 
(that is not
in a QT movie) can be be played back in QT3.0, the Open button will change to Convert.    Clicking on 
the
button will convert the file to a QT movie, save the converted movie to a specified file/directory, and 
then
import it into the current node. 

Remove Sound Button 
Clicking this button will remove the currently selected sound from the 'Sounds' list.    This button will be
grayed
out if the currently selected node has no sounds. 

Nodes List 
There will be only one item in this list if a single node pano is open. If it is a multinode pano, the name 
of each
node contained in the movie will    be displayed.    Clicking on a node list item will select it as the 



current editing
node and the sounds list box will be updated accordingly to reflect any sounds that may have been 
embedded. 

Sounds List 
This list box will be grayed out until at least one sound file is imported into the current editing node. To 
import
a sound file, use the 'Add Sound...' button.    Clicking on a "Sounds" list item will select it as the current 
editing
sound, and update the sound setting controls accordingly.    If the currently selected sound is set to be
directional, then the movie screen will be updated to display the corresponding view.    More than one 
sound can
be imported into each node, as long as there is enough available memory.    However, keep in mind 
that too
many sounds in a node can confuse the listener. 

Auto Play Button 
If this check box is selected, the audio for the current node will automatically start playing whenever 
the end
user enters the node. If this option is not selected you will need to include an external mechanism to 
start the
sound. 
    
Ambient Sound 
If the "Directional Sound" check box for a particular sound is not checked, the    sound is considered to 
be
ambient and its volume will not change based on the pan angle.    This is the default state of imported 
sounds. 
    

Setting Ambient Sound Volume 
Ambient sound volumes are set using a single control slider in the "Volume" section of the editing 
panel. 
Drag the slider thumb to the desired sound level to set playback volume.    The volume is represented 
as a
percentage of the maximum volume, and its current value is displayed in the upper right of the Volume
section. 
    

Directional Sound 
An imported sound is considered to be directional (that is, the sound volume changes based on the 
pan angle)
if the "Directional Sound" check box is checked.    The current pan angle is used when clicking on this 
check box. 
When this box is    checked, the Volume section of the editing panel will display a second volume 
control slider
and label the controls "Front" and "Rear" respectively. 
    

Setting a Sounds Direction 
The direction of a sound can be changed in two ways:    by clicking the "Directional Sound" check box 
or by
clicking the "SET ANGLE" button after panning to the desired view. 
    

Setting Directional sound volumes 
When the current sound to be edited is a directional sound, the "Volume" section of the editing panel 
displays
two control sliders and corresponding labels "Front" and "Rear". 



The slider labeled 'Front' indicates the volume that will be used when the pan angle matches the set 
direction
of the sound source. The slider labeled 'Rear' indicates the volume that will be used when the pan 
angle is 180
degrees away from direction of the sound source. 
    
Looping Style Pop Up Menu 
Selecting an item will determine the loop state of the currently selected sound to indicate type of loop
generated for playback.
          None will play the sound only once. 
          Continuous will play the sound repeatedly for the entire duration of the current node. 
          Random Delay will play the sound repeatedly with random length silence between plays. 
    

Known Issues 
---------------------------------------------------------------------------------------------------------------- 

1) Object Movies are not Supported 
Object VR movies, and multinodes which contain object nodes, are not supported. This is due to the 
differences
between the format of object movies, and panoramic movies. There are no plans to support object 
nodes, as
QuickTime currently does not have support for asynchronous track playback. As a result, this issue will 
not be
addressed by soundsaVR. 
    
    
2) Each Node in a Multinode Movie MUST have equal durations 
Movies containing nodes with different durations will NOT play properly. 

When authoring a multinode movie you    must use the same number of tiles for every node. If you are 
using
source picts of different dimensions for any reason you can use the soundsaVR QTVR Tile Calculator 
(free
HyperCard stack included with version 1.1) to help find suitable valid tile values for a set of source pict
dimensions.    This stack also stores calculated values for later reference and allows set naming and 
searching. 

Different horizontal and vertical tile dimensions can be used as long as each node still uses the same 
number
of tiles.    The following example is a compatible movie file because each node uses six tiles and will be 
of equal
duration: 
Node 1:            1 horizontal tiles                        6 vertical tiles 
Node 2:            3 horizontal tiles                        2 vertical tiles 
Node 3:            2 horizontal tiles                        3 vertical tiles 

If you have problems with a particular movie file, then please send it (or one like it) to us for testing at
"dev@smgVR.com".      You should send the original movie before it is edited with soundsaVR. 

Reporting problems 
---------------------------------------------------------------------------------------------------------------- 

soundsaVR is a new application that utilizes many components recently introduced in QuickTime 3.0. 
As a



result of the wide variety of different types of sound compressors, VR creation programs and system
configurations, it is expected that some conflicts and bugs are going to be found. 

Please consult the FAQ for information on current soundsaVR issues and bugs.      If you believe that you
have
found a different problem, please ensure that you can reproduce it, and check if it still occurs when 
starting
up with only the required standard Apple extensions. Please also make sure that all source movies and 
sounds
play correctly in MoviePlayer before they are brought into soundsaVR. 

If problems persist, please e-mail a detailed description of the problem, how it is triggered, and if 
possible, an
example source movie, as well as what program the movie was authored with, to <dev@smgVR.com> 
    

---------------------------------------------------------------------------------------------------------------- 
soundsaVR® - Copyright 1998, 1999 SQUAMISH Media Group, Inc. All rights reserved. 
soundsaVR and associated logos are registered trademarks of SQUAMISH Media Group, Inc. 
    
    


